Evo x sst

M

Mitsboy

New Member
Messages
4
Location
Manchester
Hi lad I’ve got a Evo x sst 300 remapped to 400 bhp.. when in sport I keep getting slow down msg.. I leave it to cool down then it’s fine again.. any suggestions on what it is ? Tcm, new oil cooler with fan ? Or a simple tweak that I can do myself..
 
E

Evostevie

New Member
Messages
13
Location
West Sussex UK
Hi lad I’ve got a Evo x sst 300 remapped to 400 bhp.. when in sport I keep getting slow down msg.. I leave it to cool down then it’s fine again.. any suggestions on what it is ? Tcm, new oil cooler with fan ? Or a simple tweak that I can do myself..

Are you taking the car to track days then yeah you need a bigger cooler for sure.

1/ The hot pipe to the cooler will be strapped up tight cooled return oil pipe. So the cooler won’t ever work properly. So you need to space them apart.
2/ The cooler may look like it has clear air path through it but if you take it off and sit in on top of a light source you will probably find it’s clogged up with mud in the middle. I used a bowl of hot soapy water and a cable tie to get the mud out.

400HP road use, wouldn’t normally require a bigger cooler.
 
M

Mitsboy

New Member
Messages
4
Location
Manchester
Hi Evo stevie,
Thanks for reply I only take it out 4 times a month.. as it’s my hobbie/fun car only on roads…again in normal mode never happens....
it’s only started in this hot weather..
I’ve just fully serviced the engine with shell 5w/40 & transfer,diff,Ayc..
Not sure about the spacers on the cooler hot/cold return pipes..
I had a look at it nothing blocking but i will give it a jet wash as you said with soapy water as it could be blocked I haven’t got tools & space to take it off not sure if I’ll damage something aswell..
It’s had a sst service at 50k miles
So 8 years ago..
could it need a top up of oil where the dip ?
or has the oil degraded & filters clogged up & needs service ?..
 
E

Evostevie

New Member
Messages
13
Location
West Sussex UK
Here’s a picture of the pipes, you can see them sitting together. This is just inside the nearside front wheel arch and not hard to get to, with the wheel off. I used bits of pipe as spacers and cable ties to keep the cooler pipes apart.

Pressure washing the fins may just buckle them all over. If you take the nearside wheel arch liner down you can show it some love with it in place. poke a cable tie through the gaps in the fins and spray a hose pipe jet should be enough to clear it out. It’s needs a delicate touch. high pressure water will just wreck it.


The gearbox level plug looks like the three drain plugs you’ll find here locations in the manual so you can go and verify what they look like under the car. the level plug is roughly behind the suspensions strut but horizontally beside the chassis rail so it’s hard to get to. You are best off cutting down a virgin allen key for a snug fit. Many level plugs are seized in. If you think the allen key is going slip round. Then stop and use a really long screwdriver and a 1 1/2lb hammer on the outside edge to crack it undone. Once you’ve manage it once it won’t happen again.
 

Attachments

  • 620530B6-18AD-411B-A5CD-D2904631F3A0.jpeg
    620530B6-18AD-411B-A5CD-D2904631F3A0.jpeg
    346.8 KB · Views: 1
M

Mitsboy

New Member
Messages
4
Location
Manchester
Hi thanks for reply I only got this Jdm beauty his year.. and I’m picking up the pieces to get it up to standard.. previous owners neglected the Evo.. but i will defo give the spacers a try with a little tlc clean.. I’m gonna give it a service in next few weeks.. I took it to Wales yesterday 200 miles round trip in normal auto mode no issues at all.. it only happened in sport / super sport..manual mode.. strange..
 
E

Evostevie

New Member
Messages
13
Location
West Sussex UK
Hi thanks for reply I only got this Jdm beauty his year.. and I’m picking up the pieces to get it up to standard.. previous owners neglected the Evo.. but i will defo give the spacers a try with a little tlc clean.. I’m gonna give it a service in next few weeks.. I took it to Wales yesterday 200 miles round trip in normal auto mode no issues at all.. it only happened in sport / super sport..manual mode.. strange..
In sport and even more so in SSport the clutch clamping pressures go up, the pump works a bit harder, you make a little more heat than the cooling system can handle. . You end up with the temperature getting hotter any hotter.
 
M

Mitsboy

New Member
Messages
4
Location
Manchester
Cheers evo stevie thanks for all your knowledge much appreciated..
I’ll keep you updated once I get the gearbox serviced.. I’m based in Manchester I’m gonna go Cpp to get it done 40 mikes away.. if your a local lad would you service it & I will pay you ?
 
Top